XBimmers X1   XBimmers X1
  XBimmers X1

Go Back   XBimmers | BMW X1 Forum > BMW X1 Forums > X1 DIY (Do-It-Yourself) Discussions

Post Reply
 
Thread Tools Search this Thread
      07-13-2018, 02:26 PM   #1
eyeamgrewt
Private First Class
eyeamgrewt's Avatar
16
Rep
160
Posts

Drives: 2016 M3 BSM
Join Date: Jun 2018
Location: PA

iTrader: (0)

Android Auto Install

Installed a 10.25" Android Auto 7.1 system in place of the stock 8.8" CIC system. Retains all factory functionality (backup camera, GPS, etc.). I was going to do a long-winded write up on the install process, but figured I'll just share the pics and any questions, feel free to ask.

Install was pretty straightforward, no splicing of wires- everything is plug and play. Plugs into the factory harness and I picked up a splitter to use the stock GPS antenna.

I've added a CarPlay adapter, and installed a 2-port USB plug where the factory phone cradle was.

Still working out some of the bugs, but overall pretty happy with the system. There's a big thread on the F30 forum that I've been following that's been a great help: https://f30.bimmerpost.com/forums/sh....php?t=1500481

I purchased my system from Ugode, with shipping it was $445 in total. CarPlay adapter was $70 from Amazon (there are cheaper ones on AliExpress but I wanted it sooner). The GPS splitter was $7 from AliExpress, and the USB plug was ~$10 on Ebay.

Here's what you receive- the screen, dash kit to fit the factory opening, GPS antenna (which I didn't use as I split the signal from my factory one), and all of the necessary cables to hook everything up



Dash trim removal- top climate control and lower AS/S, traction control, exo pro, etc. trim pieces pop right off with a trim removal tool



Radio trim removal was a bit trickier, as the guides that the AS/S trim panel sit on make it difficult to get these bottom clips out- best way is to remove or loosen up the center console, but I wasn't in the mood to do that so I beat the crap out of this trim piece until it finally came out (which I don't recommend doing)



All trim removed- next up was radio removal, which is held in by four screws. Again, much easier to get out with center console out of the way so those guides on either side aren't blocking the radio's bottom flanges



Next up is removing the front AC vents and surrounding trim- pretty easy to do with a trim removal tool, just pops right out. Unplug the harness for the hazards and lock switch and it's out of your way. This needs to be done to get to the two screws holding the factory screen in place.



I'm skipping ahead to the finished install as I didn't really document beyond pulling the panels and trims- but the install is pretty straightforward- again, no splicing of cables or anything. Just harnesses and plugs.

Here's the screen installed.



The Android system lets you select from several display configurations, I personally like NBT EVO ID5.



Some pics showing the CarPlay capabilities.







Here's a shot of the Android apps section w/ Play Store.



I used the old location of the phone cradle to house my USB ports. I initially wanted to install this in place of the stock cigarette lighter, but after realizing I'd have to pull apart the center console to do so, decided to find another place to house this. Also had a few vinyl decals printed up to indicate which port was for CarPlay (or Android Auto for those with Android phones) and which was for standard USB (thumb drive, external HDD, etc.).




Overall, I'm pretty pleased with the system. It has a few bugs I'm still working out, but it provides with some pretty cool functionality that the factory system doesn't. The CarPlay integration is pretty good, I use Spotify via my iPhone for the vast majority of the time, and I'm pleased with how it works here. iDrive controls work with everything on the Android side except for clicking select on CarPlay, but I believe that's more of an app limitation than system. Holding the 'menu' button on the iDrive controller for three seconds allows you to switch back and forth between factory BMW system and Android Auto. Stock backup camera works fine and switches back to previous screen once you move forward.

Any questions, feel free to ask!
Appreciate 0
      07-14-2018, 12:28 PM   #2
KWX1
Captain
KWX1's Avatar
20
Rep
64
Posts

Drives: X1 Xdrive35i
Join Date: Apr 2017
Location: Key West

iTrader: (0)

Nice, my stock screen blacks out under high heat(screen defect) and this would be a nice upgrade. What was the part or kit # for the E84. Thanks in advance.
__________________
2014 X1 Xdrive35i /BMS intake/JB4/ GFB DV/CPE charge pipe/ VRSF downpipe/ Alpina TCU flash
Appreciate 0
      07-14-2018, 04:45 PM   #3
dingo ate my baby
Enlisted Member
dingo ate my baby's Avatar
Australia
5
Rep
30
Posts

Drives: X1 20D Xdrive
Join Date: Sep 2016
Location: BNE|QLD|AUSTRALIA

iTrader: (0)

This is really cool, I think I need something like this. Good info, thanks for sharing
Appreciate 0
      07-16-2018, 03:02 PM   #4
eyeamgrewt
Private First Class
eyeamgrewt's Avatar
16
Rep
160
Posts

Drives: 2016 M3 BSM
Join Date: Jun 2018
Location: PA

iTrader: (0)

Quote:
Originally Posted by KWX1 View Post
Nice, my stock screen blacks out under high heat(screen defect) and this would be a nice upgrade. What was the part or kit # for the E84. Thanks in advance.
There isn't really a part number- the supplier is Ugode, here's their website: http://www.ugode.com/

I'd suggest emailing them directly, after some discussion with them they set up a sale on Alibaba for me to purchase.
Appreciate 0
      08-10-2018, 07:36 PM   #5
mreric
Enlisted Member
3
Rep
32
Posts

Drives: 2015 BMW X1
Join Date: Apr 2018
Location: Orange County CA

iTrader: (0)

this is very nice!!! was this plug and play? any cut and tapping to the stock wires?
Appreciate 0
      08-12-2018, 01:45 PM   #6
Danny174
New Member
0
Rep
13
Posts

Drives: BMW X1 E84 S Drive 18d
Join Date: Jun 2018
Location: London

iTrader: (0)

I have this and I can confirm this is plug and play and comes with its own harness.
Appreciate 0
      08-13-2018, 01:57 PM   #7
eyeamgrewt
Private First Class
eyeamgrewt's Avatar
16
Rep
160
Posts

Drives: 2016 M3 BSM
Join Date: Jun 2018
Location: PA

iTrader: (0)

As Danny said- completely plug and play. No splicing of any factory wires required.
Appreciate 0
      08-13-2018, 03:15 PM   #8
mreric
Enlisted Member
3
Rep
32
Posts

Drives: 2015 BMW X1
Join Date: Apr 2018
Location: Orange County CA

iTrader: (0)

wow this is great!!!!

did it come with detail well written instruction for the install?

what kind of bug have you encounter? everything works well?
Appreciate 0
      08-13-2018, 03:25 PM   #9
eyeamgrewt
Private First Class
eyeamgrewt's Avatar
16
Rep
160
Posts

Drives: 2016 M3 BSM
Join Date: Jun 2018
Location: PA

iTrader: (0)

Quote:
Originally Posted by mreric View Post
wow this is great!!!!

did it come with detail well written instruction for the install?

what kind of bug have you encounter? everything works well?
No instructions, but it's pretty straightforward if you're comfortable pulling some dash pieces out and such.

The major bug is the "no signal" issue- there seems to be a conflict with the Android unit's boot sequence and the power supplied through the factory harness. This happens when I open the vehicle and don't start it right away- i.e. if I unlock the vehicle, start loading it with stuff, and get in a few minutes later, the Android side will show 'no signal' on the screen, and only the stock CIC side will function. The supplier has provided updates which seem to have helped and they're continuously pushing out updates, so hopefully it gets addressed 100%. I haven't had the issue in a while now, and as long as I'm conscious to start my car when I open it and then do what I have to do, it's not an issue.
Appreciate 0
      08-14-2018, 04:02 PM   #10
Danny174
New Member
0
Rep
13
Posts

Drives: BMW X1 E84 S Drive 18d
Join Date: Jun 2018
Location: London

iTrader: (0)

Quote:
Originally Posted by mreric View Post
wow this is great!!!!

did it come with detail well written instruction for the install?

what kind of bug have you encounter? everything works well?
Hello this the video I used for install,
Appreciate 0
      08-14-2018, 04:03 PM   #11
Danny174
New Member
0
Rep
13
Posts

Drives: BMW X1 E84 S Drive 18d
Join Date: Jun 2018
Location: London

iTrader: (0)

Quote:
Originally Posted by mreric View Post
wow this is great!!!!

did it come with detail well written instruction for the install?

what kind of bug have you encounter? everything works well?
Hello this the video I used for install,
Appreciate 0
      08-16-2018, 05:32 PM   #12
mreric
Enlisted Member
3
Rep
32
Posts

Drives: 2015 BMW X1
Join Date: Apr 2018
Location: Orange County CA

iTrader: (0)

this is really cool system. this might entice me to keep my X1 for a bit longer as it modernize the system

have all the bugs been worked out?
Appreciate 0
      08-17-2018, 09:49 AM   #13
eyeamgrewt
Private First Class
eyeamgrewt's Avatar
16
Rep
160
Posts

Drives: 2016 M3 BSM
Join Date: Jun 2018
Location: PA

iTrader: (0)

Quote:
Originally Posted by mreric View Post
this is really cool system. this might entice me to keep my X1 for a bit longer as it modernize the system

have all the bugs been worked out?

It's been running pretty smooth for me the last several weeks. I use CarPlay 99.9% of the time, which runs pretty well.
Appreciate 0
      08-20-2018, 09:13 AM   #14
thestimp
Second Lieutenant
United_States
24
Rep
299
Posts

Drives: 09 335i e92 - 2013 X1M 35i
Join Date: Jun 2014
Location: Pittsburgh, PA

iTrader: (0)

If you wouldnt mind, what was the total cost, and which version did you get? I have emailed the company but they have not responded. I'll be in Shenzhen in october so I may just pick it up.

my 13 needs this, it feels so old school these days.
__________________
it's going to cost how much!?
Appreciate 0
      08-20-2018, 10:50 AM   #15
eyeamgrewt
Private First Class
eyeamgrewt's Avatar
16
Rep
160
Posts

Drives: 2016 M3 BSM
Join Date: Jun 2018
Location: PA

iTrader: (0)

Quote:
Originally Posted by thestimp View Post
If you wouldnt mind, what was the total cost, and which version did you get? I have emailed the company but they have not responded. I'll be in Shenzhen in october so I may just pick it up.

my 13 needs this, it feels so old school these days.
Ugode: http://www.ugode.com/

They've been pretty responsive for me and the folks on the F30 forums.

I paid $390+$55 for shipping.
Appreciate 0
      08-20-2018, 10:52 AM   #16
eyeamgrewt
Private First Class
eyeamgrewt's Avatar
16
Rep
160
Posts

Drives: 2016 M3 BSM
Join Date: Jun 2018
Location: PA

iTrader: (0)

Also, the 'no signal' issue seems to be resolved- sounds like there's a voltage discrepancy between the factory GPS signal and the Android signal. This, combined with using a GPS splitter, seems to have caused the issue.

I unplugged the splitter from the Android unit, as I really don't use the GPS on the Android unit- I use Apple Maps through CarPlay for my GPS.
Appreciate 0
      09-14-2018, 09:42 AM   #17
StevenRed
New Member
Italy
0
Rep
9
Posts

Drives: BMW X1 E84 XDrive20d
Join Date: Sep 2018
Location: Italy

iTrader: (0)

Hi guys,

my name is Stefano and I'm new in this forum.
I'm buying a similar display here in Italy and I'm asking to you if is available a software update because I saw some language mistake with italian language on a similar display mounted on my friend car and we will try to fix them or find someone who ca n fix for me.
Could you help me?
Many thanks!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:29 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST