XBimmers X1   XBimmers X1
  XBimmers X1

Go Back   XBimmers | BMW X1 Forum > BMW X1 Forums > X1 DIY (Do-It-Yourself) Discussions

Post Reply
 
Thread Tools Search this Thread
      11-15-2018, 10:54 AM   #23
AK_Wes
Enlisted Member
United_States
3
Rep
38
Posts

Drives: 2015 BMW X28i
Join Date: Oct 2018
Location: Anchorage, AK

iTrader: (0)

Quote:
Originally Posted by Chicone View Post
Thanks Wes,

How did you setup the USB port? Are the wires just sort of sticking out to the side? Iím assuming the backup cam only works when the unit is on, not when you are in the factory system? As far as Bluetooth, do you only link to the car or to both systems? What other problems are you having? So many questions, lol.

Thanks !
Hey Steve,

I ran the two included USB cords into the glove box, which once you have the dash apart is super easy to do. I haven't noticed any issues opening or closing the glove box with the wiring running in through through the top.

I'm a little confused when you ask about the backup camera only working when the unit is on..... The display is always on when you start the vehicle or have the key in the ignition, so no matter what system or display you are in the backup camera always works. The backup camera is super fast to display information and is super clear by the way. I'm really impressed by the backup camera, because it automatically displays even if the android computer hasn't finished booting after initially starting the vehicle.

The Bluetooth I initially started linking to both systems, however I just find myself using Apple CarPlay all the time now. I feel like Apple CarPlay is by far the best feature of the device if you use an iPhone that is. I also think there is a higher audio quality using Apple CarPlay, as I wasn't all that impressed with the bluetooth audio quality. I think some other folks mentioned that same issue with the bluetooth audio quality before also.

Other than these items, I am honestly not having other problems at all. I am super happy I took the time to make this modification.

Give me a shout if you need some other info or photos. Good luck if you pull the trigger on one of these units!

Wes
Appreciate 0
      11-19-2018, 06:41 AM   #24
jas_
New Member
2
Rep
9
Posts

Drives: '09 328i Convertible (e93)
Join Date: Dec 2015
Location: Louisville, KY

iTrader: (0)

Is carplay wireless a well or does it still require the cable?
Appreciate 0
      11-26-2018, 11:49 AM   #25
AK_Wes
Enlisted Member
United_States
3
Rep
38
Posts

Drives: 2015 BMW X28i
Join Date: Oct 2018
Location: Anchorage, AK

iTrader: (0)

Quote:
Originally Posted by jas_ View Post
Is carplay wireless a well or does it still require the cable?
Their version still requires the cable and Apple Car Play Adapter. I put mine in the glove box.
Appreciate 0
      12-05-2018, 06:43 AM   #26
Geoken
Enlisted Member
2
Rep
46
Posts

Drives: BMW X1 E84 2013
Join Date: Jun 2018
Location: Australia

iTrader: (0)

Quote:
Originally Posted by AK_Wes View Post
Hey Steve,

I'm a little confused when you ask about the backup camera only working when the unit is on..... The display is always on when you start the vehicle or have the key in the ignition, so no matter what system or display you are in the backup camera always works. The backup camera is super fast to display information and is super clear by the way. I'm really impressed by the backup camera, because it automatically displays even if the android computer hasn't finished booting after initially starting the vehicle.

Wes
Hey Wes,
Which camera do you have?
Appreciate 0
      12-05-2018, 11:06 AM   #27
AK_Wes
Enlisted Member
United_States
3
Rep
38
Posts

Drives: 2015 BMW X28i
Join Date: Oct 2018
Location: Anchorage, AK

iTrader: (0)

Quote:
Originally Posted by Geoken View Post
Hey Wes,
Which camera do you have?
Geoken,

I purchased this unit from AvinUSA: https://avinusa.com/bmw-trunk-releas...0-e70-e71.html

It replaces the entire trunk release handle on the back hatch. I think you can integrate this camera into any monitor system out there and it looks stock.

Have a good one.

Wes
Appreciate 0
      12-06-2018, 04:23 AM   #28
Geoken
Enlisted Member
2
Rep
46
Posts

Drives: BMW X1 E84 2013
Join Date: Jun 2018
Location: Australia

iTrader: (0)

Quote:
Originally Posted by AK_Wes View Post
Geoken,

I purchased this unit from AvinUSA: https://avinusa.com/bmw-trunk-releas...0-e70-e71.html

Wes
Thanks
Appreciate 0
      12-15-2018, 04:52 PM   #29
KWX1
Captain
KWX1's Avatar
23
Rep
77
Posts

Drives: X1 Xdrive35i
Join Date: Apr 2017
Location: Key West

iTrader: (0)

I Purchase a Avin but my original BMW CIC system will not operate?
Name:  X1 Key.png
Views: 415
Size:  602.2 KB
Thanks for any help in advance!
__________________
2014 X1 Xdrive35i /BMS intake/JB4/ GFB DV/CPE charge pipe/ VRSF downpipe/ Alpina TCU flash
Appreciate 0
      12-15-2018, 04:57 PM   #30
KWX1
Captain
KWX1's Avatar
23
Rep
77
Posts

Drives: X1 Xdrive35i
Join Date: Apr 2017
Location: Key West

iTrader: (0)

Also this harness?
Attached Images
 
__________________
2014 X1 Xdrive35i /BMS intake/JB4/ GFB DV/CPE charge pipe/ VRSF downpipe/ Alpina TCU flash
Appreciate 0
      12-17-2018, 11:44 AM   #31
AK_Wes
Enlisted Member
United_States
3
Rep
38
Posts

Drives: 2015 BMW X28i
Join Date: Oct 2018
Location: Anchorage, AK

iTrader: (0)

Quote:
Originally Posted by KWX1 View Post
I Purchase a Avin but my original BMW CIC system will not operate?
Attachment 1955252
Thanks for any help in advance!
These wires should attach to the iDrive Controller. I bought their aftermarket iDrive controller, so if you have the factory unit I'm not sure if it is the same. I missed this the first go around also.... Good luck!
Appreciate 0
      12-17-2018, 11:48 AM   #32
AK_Wes
Enlisted Member
United_States
3
Rep
38
Posts

Drives: 2015 BMW X28i
Join Date: Oct 2018
Location: Anchorage, AK

iTrader: (0)

Quote:
Originally Posted by KWX1 View Post
Also this harness?
I can't read what the writing says on that harness in your photo..... I am also drawing a blank of where I hooked that up in my car for some reason, even though it wasn't all that long ago.

Feel free to post up a photo where I can read the writing and I'll take a look again. I know that the non existent instructions with this kit were kind of a pain. Even including a simple 10 page print out would have helped quite a bit.
Appreciate 0
      12-17-2018, 04:26 PM   #33
KWX1
Captain
KWX1's Avatar
23
Rep
77
Posts

Drives: X1 Xdrive35i
Join Date: Apr 2017
Location: Key West

iTrader: (0)

Quote:
Originally Posted by AK_Wes View Post
I can't read what the writing says on that harness in your photo..... I am also drawing a blank of where I hooked that up in my car for some reason, even though it wasn't all that long ago.

Feel free to post up a photo where I can read the writing and I'll take a look again. I know that the non existent instructions with this kit were kind of a pain. Even including a simple 10 page print out would have helped quite a bit.
Thanks for the reply. It is all in Chinese except for the small green connector which also printed in English says CAN1.
__________________
2014 X1 Xdrive35i /BMS intake/JB4/ GFB DV/CPE charge pipe/ VRSF downpipe/ Alpina TCU flash
Appreciate 0
      12-21-2018, 01:54 PM   #34
KWX1
Captain
KWX1's Avatar
23
Rep
77
Posts

Drives: X1 Xdrive35i
Join Date: Apr 2017
Location: Key West

iTrader: (0)

Problem solved. The setting "Old X1" was applied. This shuts down the CIC system.
Unfortunately, I had to start a Paypal claim to get any support from Avin.
Thanks for all the input and yes the wires labeled "X1 Key" are for an added Idrive controller.
__________________
2014 X1 Xdrive35i /BMS intake/JB4/ GFB DV/CPE charge pipe/ VRSF downpipe/ Alpina TCU flash
Appreciate 0
      12-31-2018, 12:46 PM   #35
AK_Wes
Enlisted Member
United_States
3
Rep
38
Posts

Drives: 2015 BMW X28i
Join Date: Oct 2018
Location: Anchorage, AK

iTrader: (0)

Quote:
Originally Posted by KWX1 View Post
Problem solved. The setting "Old X1" was applied. This shuts down the CIC system.
Unfortunately, I had to start a Paypal claim to get any support from Avin.
Thanks for all the input and yes the wires labeled "X1 Key" are for an added Idrive controller.
Good to hear you figured it out!!! I didn't have any issues with the CIC System, so I'm sorry I couldn't be any help there.

The Avin guy wasn't all that responsive for me either, so I was in the same boat as you for a little bit. I had to resend the same question a couple times to get a response. Hopefully you think this system is worth the $, as I think it is a huge improvement even with some of the hassle.
Appreciate 0
      01-04-2019, 04:28 PM   #36
mikeyb540
New Member
0
Rep
9
Posts

Drives: '13 X1 E84
Join Date: Feb 2013
Location: US

iTrader: (0)

Quote:
Originally Posted by AK_Wes View Post
I bought everything for my system from here: https://avinusa.com/10-25-bmw-x1-ser...on-system.html

Mine took a bit longer to install, because I had to install a backup camera and idrive controller as my X1 didn't come with those options. I definitely suggest getting the hardwired backup camera rather than the wireless if you are looking at this system.

Let me know if you have any questions.
Hi there, i have the 2013 x1 e84. Same as you, i didnt have the camera nor idrive. What steps did you follow for the install? thanks
Appreciate 0
      01-07-2019, 02:24 PM   #37
AK_Wes
Enlisted Member
United_States
3
Rep
38
Posts

Drives: 2015 BMW X28i
Join Date: Oct 2018
Location: Anchorage, AK

iTrader: (0)

Quote:
Originally Posted by mikeyb540 View Post
Hi there, i have the 2013 x1 e84. Same as you, i didnt have the camera nor idrive. What steps did you follow for the install? thanks
Hey Mikey,

There is a YouTube video posted earlier on in this thread that I followed for the majority of the install. It's not from Avin, but another company based out of Canada. Everything from Avin looks exactly identical to what the Canadian video is showing for installation though.

For the backup camera, don't try to tap into your reverse lights, as they don't supply enough power for the camera (I tried this and failed). I ran the wiring from the backup camera under the carpet and floor trim all the way to the head unit, which really wasn't all that difficult. Just make sure you buy a trim removal kit before undertaking the installation, those tools make your life much easier and prevent damage. I just searched on Amazon.com for one and bought the most popular version. I also suggest you buy a wire fishing tool, unless you already have one in your garage. I already had one for some home projects and it makes life quite a bit easier, especially feeding new wire through from the rear hatch to the cab of the vehicle.

Give me a shout if you run into any trouble.

Wes
Appreciate 0
      01-20-2019, 08:03 PM   #38
mikeyb540
New Member
0
Rep
9
Posts

Drives: '13 X1 E84
Join Date: Feb 2013
Location: US

iTrader: (0)

thanks Wes! im all setup now with the camera and just ordered the iDrive. Trying to find a discounted Sat Activation. Did you do it?
Appreciate 0
      01-21-2019, 10:40 AM   #39
AK_Wes
Enlisted Member
United_States
3
Rep
38
Posts

Drives: 2015 BMW X28i
Join Date: Oct 2018
Location: Anchorage, AK

iTrader: (0)

Quote:
Originally Posted by mikeyb540 View Post
thanks Wes! im all setup now with the camera and just ordered the iDrive. Trying to find a discounted Sat Activation. Did you do it?
Discounted Sat Activation?????

Sorry, I'm not sure what you are referencing when you talk about sat activation. Are you trying to activate the stock BMW system?

You can download any navigation software you want onto the android system once you get it installed, and then you pick which one the navigation icon defaults to when pressed. I tried a few different options.... Sygic, Google Maps, and Waze. I ended up settling on Waze for my default navigation app, but it's all about personal preference. Sygic was just too busy for me and if I remember correctly it kept asking me to upgrade to premium (annoying).

Hopefully this helps, let me know if I'm missing something with the sat activation.

Wes
Appreciate 0
      01-21-2019, 01:25 PM   #40
mikeyb540
New Member
0
Rep
9
Posts

Drives: '13 X1 E84
Join Date: Feb 2013
Location: US

iTrader: (0)

Quote:
Originally Posted by AK_Wes View Post
Discounted Sat Activation?????

Sorry, I'm not sure what you are referencing when you talk about sat activation. Are you trying to activate the stock BMW system?
Yep! trying to activate the Sirius capability on the radio unit. I didnt get the Tech nor Premium package when i bought the car.

Dealer wants >$600 to activate Sirius. Found retrofits that do it but its still steep around $300. I see some other members got it coded for $160
Appreciate 0
      01-27-2019, 10:21 AM   #41
vfonseca
Registered
0
Rep
2
Posts

Drives: X1 E84
Join Date: Jan 2019
Location: Portugal

iTrader: (0)

HI,

Thanks for the diy.
I bought a GPS splitter but can't connect it to the stock GPS cable (the input is very large for
The stock Connector)
https://avinusa.com/media/catalog/product/cache/1/image/720x/12e96982480421c15a5baed61d04ef30/g/p/gps_splitter.jpg

Which splitter did you use?

Quote:
Originally Posted by eyeamgrewt View Post
Installed a 10.25" Android Auto 7.1 system in place of the stock 8.8" CIC system. Retains all factory functionality (backup camera, GPS, etc.). I was going to do a long-winded write up on the install process, but figured I'll just share the pics and any questions, feel free to ask.

Install was pretty straightforward, no splicing of wires- everything is plug and play. Plugs into the factory harness and I picked up a splitter to use the stock GPS antenna.

I've added a CarPlay adapter, and installed a 2-port USB plug where the factory phone cradle was.

Still working out some of the bugs, but overall pretty happy with the system. There's a big thread on the F30 forum that I've been following that's been a great help: https://f30.bimmerpost.com/forums/sh....php?t=1500481

I purchased my system from Ugode, with shipping it was $445 in total. CarPlay adapter was $70 from Amazon (there are cheaper ones on AliExpress but I wanted it sooner). The GPS splitter was $7 from AliExpress, and the USB plug was ~$10 on Ebay.

Here's what you receive- the screen, dash kit to fit the factory opening, GPS antenna (which I didn't use as I split the signal from my factory one), and all of the necessary cables to hook everything up



Dash trim removal- top climate control and lower AS/S, traction control, exo pro, etc. trim pieces pop right off with a trim removal tool



Radio trim removal was a bit trickier, as the guides that the AS/S trim panel sit on make it difficult to get these bottom clips out- best way is to remove or loosen up the center console, but I wasn't in the mood to do that so I beat the crap out of this trim piece until it finally came out (which I don't recommend doing)



All trim removed- next up was radio removal, which is held in by four screws. Again, much easier to get out with center console out of the way so those guides on either side aren't blocking the radio's bottom flanges



Next up is removing the front AC vents and surrounding trim- pretty easy to do with a trim removal tool, just pops right out. Unplug the harness for the hazards and lock switch and it's out of your way. This needs to be done to get to the two screws holding the factory screen in place.



I'm skipping ahead to the finished install as I didn't really document beyond pulling the panels and trims- but the install is pretty straightforward- again, no splicing of cables or anything. Just harnesses and plugs.

Here's the screen installed.



The Android system lets you select from several display configurations, I personally like NBT EVO ID5.



Some pics showing the CarPlay capabilities.







Here's a shot of the Android apps section w/ Play Store.



I used the old location of the phone cradle to house my USB ports. I initially wanted to install this in place of the stock cigarette lighter, but after realizing I'd have to pull apart the center console to do so, decided to find another place to house this. Also had a few vinyl decals printed up to indicate which port was for CarPlay (or Android Auto for those with Android phones) and which was for standard USB (thumb drive, external HDD, etc.).




Overall, I'm pretty pleased with the system. It has a few bugs I'm still working out, but it provides with some pretty cool functionality that the factory system doesn't. The CarPlay integration is pretty good, I use Spotify via my iPhone for the vast majority of the time, and I'm pleased with how it works here. iDrive controls work with everything on the Android side except for clicking select on CarPlay, but I believe that's more of an app limitation than system. Holding the 'menu' button on the iDrive controller for three seconds allows you to switch back and forth between factory BMW system and Android Auto. Stock backup camera works fine and switches back to previous screen once you move forward.

Any questions, feel free to ask!
Appreciate 0
      01-30-2019, 10:06 PM   #42
Chicone
Private
15
Rep
81
Posts

Drives: 2015 X1 X35i M-SPORT
Join Date: Jun 2018
Location: Seattle, Wa

iTrader: (0)

I can’t help but think that a aftermarket wireless CarPlay solution will become available. It’s starting to ship now in some aftermarket head units from Alpine and others. The solution here is a CarPlay dongle “hack” that connects to the Android system, seems like someone could produce a wireless dongle. Also not sure about Avin from the comments here, tempted to go with https://4x4shop.ca as they seem more user friendly.
__________________
-Steve

2015 BMW X1 35i MSport // BMS Intake
Appreciate 0
      02-04-2019, 12:36 PM   #43
beemer420
Registered
0
Rep
1
Posts

Drives: 2013 BMW 328 I,2014 BMW X1
Join Date: Feb 2019
Location: Texas

iTrader: (0)

Hi AK:

I got a similar install done in my 2014 X1 and replaced the storage compartment with PX6 Android 8.1 Version 6 Core with 2GB RAM /32GB Storage. Also installed a back up camera. Also installed CarPlay dongle. I am connected to the head units BT and when I attach the cable to the car play dongle , SIRI is not taking any voice commands. Also making calls while using Car Play, I can hear the other person but no one can hear my voice. Also I hear a static sound when someone calls me. Also Music starts and pauses from Iphone? Did you encounter any of these issues? TIA
Appreciate 0
      02-06-2019, 08:27 PM   #44
jamesonmcmaster
Registered
0
Rep
1
Posts

Drives: 2015 BMW x1
Join Date: Jan 2019
Location: Ohio

iTrader: (0)

Quote:
Originally Posted by AK_Wes View Post
I bought everything for my system from here: https://avinusa.com/10-25-bmw-x1-ser...on-system.html

Mine took a bit longer to install, because I had to install a backup camera and idrive controller as my X1 didn't come with those options. I definitely suggest getting the hardwired backup camera rather than the wireless if you are looking at this system.

Let me know if you have any questions.
This is all great, I've been looking into this as well. I just bought a 2015 x1 without iDrive. This might be a dumb question, but if you don't have iDrive you can't install actual iDrive and all its functionality, right?

So the system you bought came with the screen, backup camera and iDrive console controller? Was it fairly easy to install? Do you recommend doing it?

Thanks!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:49 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST