XBimmers X1   XBimmers X1
  XBimmers X1

Go Back   XBimmers | BMW X1 Forum > BMW X1 Forums > General BMW X1 (E84) Forum

Post Reply
 
Thread Tools Search this Thread
      04-27-2013, 03:20 PM   #1
Blackwood74
Registered
 
Drives: 2012 x1
Join Date: Apr 2013
Location: St. John's, nl, Canada

Posts: 3
iTrader: (0)

N20 engine malfunction light

Folks,

I'm new to this forum. I have a 2012 X1 xdrive28i with 19,000kms on it. I've had the car for a year with no issues whatsoever until this weekend.

On a road trip i was on the engine lost significant power and this Engine Malfunction Loss of Power code appeared. I turned off the engine and waited, restarted and the code cleared and all was fine. Upon my return home the code appeared 3 more times.

I do have an appt scheduled for Monday. Has anyone here experienced this and what came from it?

Cheers
Blackwood74 is offline  
0
Reply With Quote
      04-27-2013, 03:39 PM   #2
edx1
Private First Class
 
Drives: X1 xDrive35i
Join Date: Oct 2012
Location: Wasatch front

Posts: 192
iTrader: (0)

Not really, maybe check your gas cap.

I also watch the other forums with the same engine and haven't seen any "common" reasons for any engine errors. There have been very few reports of problems so far.
edx1 is offline  
0
Reply With Quote
      04-27-2013, 03:55 PM   #3
HotRodW
Second Lieutenant
 
HotRodW's Avatar
 
Drives: 2013 X1 xDrive28i M Sport
Join Date: Sep 2012
Location: Southwest Michigan

Posts: 232
iTrader: (0)

Fuel injector? A few have reported problems with those.
HotRodW is offline   United_States
0
Reply With Quote
      04-27-2013, 06:19 PM   #4
CIWS
Moon Parasite
 
CIWS's Avatar
 
Drives: X1 35i Sport (was)X6 50i Dinan
Join Date: Sep 2011
Location: D/FW

Posts: 343
iTrader: (0)

Check with your local auto parts store and see if they will read the codes for you, it won't tell you a bad part per se (unless a gas cap) but it will give the code(s) for whatever malfunctions it saw.
__________________
CIWS is offline   United_States
0
Reply With Quote
      04-30-2013, 07:12 AM   #5
Blackwood74
Registered
 
Drives: 2012 x1
Join Date: Apr 2013
Location: St. John's, nl, Canada

Posts: 3
iTrader: (0)

Thought I'd update you all. Looks like the turbo wastegate system failed. It's a fairly extensive job but its under warranty. They gave me a 2012 3 series loaner which is quite nice.
Blackwood74 is offline  
0
Reply With Quote
      04-30-2013, 08:26 AM   #6
edx1
Private First Class
 
Drives: X1 xDrive35i
Join Date: Oct 2012
Location: Wasatch front

Posts: 192
iTrader: (0)

Quote:
Originally Posted by Blackwood74 View Post
Thought I'd update you all. Looks like the turbo wastegate system failed. It's a fairly extensive job but its under warranty. They gave me a 2012 3 series loaner which is quite nice.
This is now the second one I've heard of going bad...
edx1 is offline  
0
Reply With Quote
      03-01-2014, 05:37 PM   #7
Naambezet
Second Lieutenant
 
Drives: BMW X1 sDrive 20i
Join Date: Apr 2012
Location: Netherlands

Posts: 282
iTrader: (0)

I had the same issue today, the engine was very jerky and the whole car was shaking when idling. Got an appointment friday for a checkup (not related to this)
Naambezet is offline   Netherlands
0
Reply With Quote
      03-02-2014, 07:32 AM   #8
Yarvis
Private
 
Yarvis's Avatar
 
Drives: 2013 BMW X1 x28i
Join Date: Oct 2013
Location: Staten Island, NY

Posts: 68
iTrader: (0)

What is the turbo wastegate issue some have complained about?
__________________
"Life is what happens to you while you're busy making other plans"......John Lennon
Yarvis is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:58 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST