XBimmers X1   XBimmers X1
  XBimmers X1

Go Back   XBimmers | BMW X1 Forum > BMW X1 Forums > General BMW X1 (E84) Forum

Post Reply
 
Thread Tools Search this Thread
      11-04-2012, 05:17 PM   #1
sfillion
Enlisted Member
Canada
0

 
Drives: 2012 X1 xDrive28i & 128i M
Join Date: Dec 2009
Location: Montreal, Canada


Posts: 41
iTrader: (0)

Winter tires/Wheels installed (pictures)

Hi,
I just installed my winter wheels.

17x7.5 MSW Type 22 BLK PAINT
225/50R-17 Michelin Pilot Alpin PA2 ZP Run Flat

Quick Question. I Have the Sport Package with 18" Wheels. The inflate PSI is 35\front and 38\back. Does someone can tell me if I should inflate my tires with the same pressure since I installed 17" wheels instead of 18" ?

This is somes pictures of before and after :
Attached Images
    
Appreciate 0
      11-04-2012, 08:41 PM   #2
popopine
Private
United_States
3

 
Drives: Black X1 X-line
Join Date: Aug 2012
Location: North East US


Posts: 77
iTrader: (0)

BADASS
Appreciate 0
      11-04-2012, 09:29 PM   #3
dinamo
Enlisted Member
Canada
0

 
dinamo's Avatar
 
Drives: 2012 BMW X1 xDrive28i
Join Date: Sep 2011
Location: Calgary


Posts: 41
iTrader: (0)

WU -- Wuerzburger license plates , I've been there couple times .... Bavaria ...
__________________
2012 E84 Sapphire Black xDrive28i with Premium ,Comfort Access, PDC,Electrical Seat/Memory
Appreciate 0
      11-04-2012, 09:31 PM   #4
HotRodW
Second Lieutenant
United_States
3

 
HotRodW's Avatar
 
Drives: 2013 X1 xDrive28i M Sport
Join Date: Sep 2012
Location: Southwest Michigan


Posts: 232
iTrader: (0)

Looks good. Any problem resetting your TPM system? Mine won't reset with the winters.

BTW, I'm using the factory pressure settings until instructed otherwise.

Last edited by HotRodW; 11-04-2012 at 09:37 PM.
Appreciate 0
      11-04-2012, 09:49 PM   #5
pokerface
Lieutenant Colonel
Canada
24

 
pokerface's Avatar
 
Drives: B8 A4 2.0T
Join Date: Apr 2006
Location: Toronto


Posts: 1,690
iTrader: (1)

HottRodW, does your US spec car have tire pressure sensors? In Canada we only have flat tire monitors (detects flats via speed of wheel spin).
__________________
F25 X3 N20:

2010 B8 A4 2.0T quattro (current)/
2013 F25 X3 x28 N20 (babymobile)
Appreciate 0
      11-04-2012, 09:58 PM   #6
HotRodW
Second Lieutenant
United_States
3

 
HotRodW's Avatar
 
Drives: 2013 X1 xDrive28i M Sport
Join Date: Sep 2012
Location: Southwest Michigan


Posts: 232
iTrader: (0)

Quote:
Originally Posted by pokerface View Post
HottRodW, does your US spec car have tire pressure sensors? In Canada we only have flat tire monitors (detects flats via speed of wheel spin).
Yeah, we have sensors here in the US. I bought my package from the Tire Rack. I have a feeling they either forgot the sensors, gave me a bad one or installed sensors with the wrong frequency. Unfortunately, it looks like I have to make a trip to the dealer to find out.

Sorry, sfillion - I'm not trying to jack your thread.
Appreciate 0
      11-04-2012, 10:37 PM   #7
pokerface
Lieutenant Colonel
Canada
24

 
pokerface's Avatar
 
Drives: B8 A4 2.0T
Join Date: Apr 2006
Location: Toronto


Posts: 1,690
iTrader: (1)



OP, How is the fitment with the brakes? To answer your question about tire pressure - they should be the same as your factory 18s.
__________________
F25 X3 N20:

2010 B8 A4 2.0T quattro (current)/
2013 F25 X3 x28 N20 (babymobile)
Appreciate 0
      11-05-2012, 01:40 AM   #8
Blue Bottle
Lieutenant
Netherlands
7

 
Blue Bottle's Avatar
 
Drives: X1 x Drive 2.0L D
Join Date: Oct 2011
Location: Near Heerlen


Posts: 532
iTrader: (0)

Looks great buddy, bet you are hoping for snow now....
Appreciate 0
      11-05-2012, 06:27 AM   #9
sfillion
Enlisted Member
Canada
0

 
Drives: 2012 X1 xDrive28i & 128i M
Join Date: Dec 2009
Location: Montreal, Canada


Posts: 41
iTrader: (0)

Quote:
Originally Posted by pokerface View Post


OP, How is the fitment with the brakes? To answer your question about tire pressure - they should be the same as your factory 18s.
Perfect fit with the brakes. Tks for tire pressure.
Appreciate 0
      11-05-2012, 06:28 AM   #10
sfillion
Enlisted Member
Canada
0

 
Drives: 2012 X1 xDrive28i & 128i M
Join Date: Dec 2009
Location: Montreal, Canada


Posts: 41
iTrader: (0)

Quote:
Originally Posted by dinamo View Post
WU -- Wuerzburger license plates , I've been there couple times .... Bavaria ...
Good to know. Thanks fo the information... I didn't know fo WU.
Appreciate 0
      11-05-2012, 06:31 AM   #11
sfillion
Enlisted Member
Canada
0

 
Drives: 2012 X1 xDrive28i & 128i M
Join Date: Dec 2009
Location: Montreal, Canada


Posts: 41
iTrader: (0)

Quote:
Originally Posted by HottRodW View Post
Looks good. Any problem resetting your TPM system? Mine won't reset with the winters.

BTW, I'm using the factory pressure settings until instructed otherwise.
Has Pokerface said, in Canada we do not have tire pressure. I think they use the ABS sensor.
Appreciate 0
      11-05-2012, 06:35 AM   #12
sfillion
Enlisted Member
Canada
0

 
Drives: 2012 X1 xDrive28i & 128i M
Join Date: Dec 2009
Location: Montreal, Canada


Posts: 41
iTrader: (0)

Quote:
Originally Posted by Blue Bottle View Post
Looks great buddy, bet you are hoping for snow now....
Yep, my two cars and my ski are ready for a long ski season....
Appreciate 0
      11-05-2012, 11:21 AM   #13
libertycrd
New Member
Canada
0

 
Drives: X1 xDrive28i
Join Date: Nov 2011
Location: quebec, canada


Posts: 7
iTrader: (0)

Nice wheels!

did you order them on Tirerack?

I tried some RTX Berlin replica on my X1 and they don't fit...

So i am looking for other wheels and i don't want to buy other wheels that don't fit.

I have also the sport package with the 18' wheels, even if it seems that it doesn't change anything about the brakes diameter.

Thanks
Appreciate 0
      11-05-2012, 02:40 PM   #14
netarc
New Member
0

 
Drives: Audi A3
Join Date: Sep 2012
Location: SF Bay Area


Posts: 25
iTrader: (0)

Quote:
Originally Posted by HottRodW View Post
Yeah, we have sensors here in the US. I bought my package from the Tire Rack. I have a feeling they either forgot the sensors, gave me a bad one or installed sensors with the wrong frequency. Unfortunately, it looks like I have to make a trip to the dealer to find out.

Sorry, sfillion - I'm not trying to jack your thread.
I was about to order a set of MSW 22s and Bridgestone Blizzak WS70 215/55R17 from tirerack; I think (need to confirm) that these are runflats.

However, now I'm concerned about the tire monitoring and whether this'd work on a US spec car. HotRod, did you contact TireRack, were they able to confirm/resolve the issue with your set?
Appreciate 0
      11-05-2012, 04:02 PM   #15
HotRodW
Second Lieutenant
United_States
3

 
HotRodW's Avatar
 
Drives: 2013 X1 xDrive28i M Sport
Join Date: Sep 2012
Location: Southwest Michigan


Posts: 232
iTrader: (0)

netarc - I don't want to jack this thread any more than I already have. I'll send you a PM.
Appreciate 0
      12-05-2012, 02:30 PM   #16
Naambezet
Second Lieutenant
Netherlands
2

 
Drives: BMW X1 sDrive 20i
Join Date: Apr 2012
Location: Netherlands


Posts: 288
iTrader: (0)

German plates and fugly amber reflectors?
Appreciate 0
      12-05-2012, 02:33 PM   #17
nospam
Captain
8

 
Drives: X1 x28i; 128i; S2000
Join Date: Jul 2010
Location: Orange County, CA


Posts: 672
iTrader: (0)

Looks really good!
Appreciate 0
      12-07-2012, 08:50 PM   #18
X1 white pearl
Enlisted Member
Canada
3

 
Drives: BMW X1 28I xdrive 2012
Join Date: Jul 2011
Location: Quebec city


Posts: 38
iTrader: (0)

Quote:
Originally Posted by sfillion View Post
Hi,
I just installed my winter wheels.

17x7.5 MSW Type 22 BLK PAINT
225/50R-17 Michelin Pilot Alpin PA2 ZP Run Flat

Quick Question. I Have the Sport Package with 18" Wheels. The inflate PSI is 35\front and 38\back. Does someone can tell me if I should inflate my tires with the same pressure since I installed 17" wheels instead of 18" ?

This is somes pictures of before and after :
I have the same problem as you, rust is starting to take place on the wheel hub inside.
Appreciate 0
      12-07-2012, 09:49 PM   #19
nospam
Captain
8

 
Drives: X1 x28i; 128i; S2000
Join Date: Jul 2010
Location: Orange County, CA


Posts: 672
iTrader: (0)

Quote:
Originally Posted by X1 white pearl View Post
I have the same problem as you, rust is starting to take place on the wheel hub inside.
Centric brand premium rotors are coated black and do not rust (Zeckhausen Racing). I used to always use these on my E39 and E46. They also make it easier to change rotors if you do your own maintenance. Now that BMW covers brakes and rotors under the included maintenance, I just deal with the rust.

Appreciate 0
      12-08-2012, 07:36 PM   #20
X1 white pearl
Enlisted Member
Canada
3

 
Drives: BMW X1 28I xdrive 2012
Join Date: Jul 2011
Location: Quebec city


Posts: 38
iTrader: (0)

Quote:
Originally Posted by nospam View Post
Centric brand premium rotors are coated black and do not rust (Zeckhausen Racing). I used to always use these on my E39 and E46. They also make it easier to change rotors if you do your own maintenance. Now that BMW covers brakes and rotors under the included maintenance, I just deal with the rust.

Good to know.
Appreciate 0
      12-12-2012, 02:42 PM   #21
ohnoyuji
Private First Class
7

 
Drives: Mini Cooper/ BMW X1 i28
Join Date: May 2011
Location: Montreal


Posts: 187
iTrader: (0)

Quote:
Originally Posted by X1 white pearl View Post
I have the same problem as you, rust is starting to take place on the wheel hub inside.
Had same problem, but just use a brush, the rust is superficial, it's gone without any cleaners.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:52 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST