XBimmers X1   XBimmers X1
  XBimmers X1

Go Back   XBimmers | BMW X1 Forum > BMW X1 Forums > X1 DIY (Do-It-Yourself) Discussions

Post Reply
 
Thread Tools Search this Thread
      08-07-2017, 05:03 AM   #1
rkl
New Member
0
Rep
8
Posts

Drives: BMW 320 e90
Join Date: Mar 2013
Location: New Zealand

iTrader: (0)

New e84 Owner, after some help

Hey guy
sorry to be the guy on the forum who only asks help. I know how that looks (normally a big contributor to a honda forum in NZ).
But hoping someone can help me out with some knowledge.
I'm fairly confident with mechanical and electrical work and have used NCS to code my old e90 before.


Just picked up a x28i Xline from Japan. Has iDrive
Few things I need a hand with -
Can I retrofit a reversing camera, From what I have read I can as I have both front and rear PCD.
Has anyone done this? and if so whats involved. Is it just a matter of camera and then coding?
It looks like there is a blanked out spot on the tailgate ready for a camera.

Can I enable bluetooth, for phones and music,
I have iDrive and have options
S6FL USB/Audio interface
S6VC Control for Combox
But no bluetooth option on the I drive menu.
Again from what I read it could be a matter of adding an antenna and coding?

Lastly has anyone coded a region change for the iDrive radio?
Not fussed about navigation (as google maps is better anyway with traffic) but it would be good to have OCEANIA channels for my radio.

ps going to trall the forums now, but if you know of any other nifty features and may be tricky to realise, or that I can code in let me know!
TIA
Appreciate 0
      08-07-2017, 09:34 PM   #2
d1saster
Lieutenant
Bulgaria
25
Rep
546
Posts

Drives: X1 s28i
Join Date: Oct 2012
Location: Las Vegas

iTrader: (0)

You can install non oem reverse camera with emulator as I doubt the rdc module has the camera option.

For the region you need to change your VO (vehicle order) and default code the cic module.

For the Bluetooth you need to check what kind of media module you have (ulf, combox...)
Appreciate 0
      08-08-2017, 01:27 AM   #3
rkl
New Member
0
Rep
8
Posts

Drives: BMW 320 e90
Join Date: Mar 2013
Location: New Zealand

iTrader: (0)

Thanks for the response
yea thinking it might be easier to install a aftermarket camera.
'What would be the best way to check media module?
Appreciate 0
      08-10-2017, 01:35 AM   #4
d1saster
Lieutenant
Bulgaria
25
Rep
546
Posts

Drives: X1 s28i
Join Date: Oct 2012
Location: Las Vegas

iTrader: (0)

I assume you don't have obd cable and bmw standard tools (software package). You can lift the trunk bottom to see the media module name and number.
Appreciate 0
      08-10-2017, 04:10 AM   #5
rkl
New Member
0
Rep
8
Posts

Drives: BMW 320 e90
Join Date: Mar 2013
Location: New Zealand

iTrader: (0)

Yes have a dcan cable and NCS, INPA and pretty sure have standard tools (but haven't played with it)
Have plugged into the car yet as it's going through compliance here in NZ. Will look at the module physically over the weekend
Appreciate 0
      08-10-2017, 03:55 PM   #6
d1saster
Lieutenant
Bulgaria
25
Rep
546
Posts

Drives: X1 s28i
Join Date: Oct 2012
Location: Las Vegas

iTrader: (0)

NCS and inpa are part of standard tools Reading a module will not change anything on the car. I suggest to read the module with ncsexpert and open the trace file with ncsdummy to see what options you have.
Appreciate 0
      08-10-2017, 08:05 PM   #7
rkl
New Member
0
Rep
8
Posts

Drives: BMW 320 e90
Join Date: Mar 2013
Location: New Zealand

iTrader: (0)

Thanks D1saster, will see how I go. Been a couple of years since I done some coding. Was with my base spec e90 that didnt have most codeable options anyway.
Will reply once I have had a play!
Appreciate 0
      08-10-2017, 09:42 PM   #8
d1saster
Lieutenant
Bulgaria
25
Rep
546
Posts

Drives: X1 s28i
Join Date: Oct 2012
Location: Las Vegas

iTrader: (0)

What year was the e90? Early ones used k-dcan protocol. E84 uses dcan.
Appreciate 0
      Today, 05:56 AM   #9
rkl
New Member
0
Rep
8
Posts

Drives: BMW 320 e90
Join Date: Mar 2013
Location: New Zealand

iTrader: (0)

Holy threat revival batman!,
sorry I have been away so didnt get to work on this.
I have coded the radio for radio stations in NZ.
Didnt bother changing the VO to match for now.

Purchased a emulator for the camera, havnt got it working as yet. Coding looks successful as it shows the options but am not getting any image, so suspect hardware issue. Possibly faulty emulator.

Fairly certain I have combox the CIC module shows all the options for a bluetooth system. So would it be a matter of hardware then coding?
Unsure of part numbers, but think i need the antennna, mic and cable from combox to ??
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:00 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST