XBimmers X1   XBimmers X1
  XBimmers X1

Go Back   XBimmers | BMW X1 Forum > BMW X1 Forums > General BMW X1 (E84) Forum

Post Reply
 
Thread Tools Search this Thread
      05-01-2010, 10:39 PM   #1
jasonkhan
Registered
1

 
Drives: X1 23d
Join Date: May 2010
Location: Brisbane, Australia


Posts: 3
iTrader: (0)

Professional Nav / Media Player

Just taken delivery of an X1 23d with Professional Nav

1. The voice input for addresses seems to be disabled in the Australian model... or is it a problem with mine? It returns an error and says function is currently unavailable

2. I have loaded WMA's onto the hard drive. I have turned on RANDOM, but it seems to forget the random setting between car starts. Is this by design or a problem with my unit.

Thanks.
Appreciate 0
      05-02-2010, 03:15 PM   #2
niknik
Private First Class
Portugal
7

 
Drives: X1 23d
Join Date: Apr 2010
Location: Portugal


Posts: 113
iTrader: (0)

Voice input is an extra, even if you choose the navigation system.
Appreciate 0
      05-02-2010, 03:42 PM   #3
jasonkhan
Registered
1

 
Drives: X1 23d
Join Date: May 2010
Location: Brisbane, Australia


Posts: 3
iTrader: (0)

yes, I have voice input

i say "destination input" and it responds with "that function is currently unavailable"

it seems to respond to music searches fine.
Appreciate 0
      05-03-2010, 03:57 AM   #4
niknik
Private First Class
Portugal
7

 
Drives: X1 23d
Join Date: Apr 2010
Location: Portugal


Posts: 113
iTrader: (0)

That's weird indeed... Any luck with your dealer telling you what's happening?
Appreciate 0
      05-30-2010, 02:37 AM   #5
frayedsheet
Private
Australia
10

 
Drives: 2012 Jeep GC Overland
Join Date: Dec 2009
Location: Sydney, Australia


Posts: 81
iTrader: (0)

Quote:
Originally Posted by jasonkhan View Post
Just taken delivery of an X1 23d with Professional Nav

1. The voice input for addresses seems to be disabled in the Australian model... or is it a problem with mine? It returns an error and says function is currently unavailable

2. I have loaded WMA's onto the hard drive. I have turned on RANDOM, but it seems to forget the random setting between car starts. Is this by design or a problem with my unit.

Thanks.

does anyone know what the hard drive capacity for music storage is? Also, are some of the more interesting things available in australia for the professional nav system... eg BMW online? Internet access?
Appreciate 0
      05-30-2010, 06:13 AM   #6
nagelixin
Enlisted Member
4

 
Drives: X1
Join Date: May 2010
Location: AU


Posts: 46
iTrader: (0)

Quote:
Originally Posted by frayedsheet View Post
does anyone know what the hard drive capacity for music storage is? Also, are some of the more interesting things available in australia for the professional nav system... eg BMW online? Internet access?
80gb if I recall correctly.

Internet is only in Germany at this stage.
Appreciate 0
      05-30-2010, 06:38 AM   #7
niknik
Private First Class
Portugal
7

 
Drives: X1 23d
Join Date: Apr 2010
Location: Portugal


Posts: 113
iTrader: (0)

Quote:
Originally Posted by nagelixin View Post
80gb if I recall correctly.

Internet is only in Germany at this stage.
We really should press BMW to allow internet access in other countries, via the smartphone internet connection, or maybe even via bluetooth (iPhone, etc.)

It would be great.

As it is, I find it rather lacking, not to have my BMW "online", and having no option to do it.
Appreciate 0
      05-30-2010, 04:26 PM   #8
Dark-Sider
X1 driver
Germany
0

 
Drives: X1 1.8d sDrive
Join Date: Mar 2010
Location: Munich, Germany


Posts: 63
iTrader: (0)

Hi,

Quote:
Originally Posted by nagelixin View Post
80gb if I recall correctly.

Internet is only in Germany at this stage.
The Harddisk is 80GB, but only 12GB are usable for downloading music. The remaining space is for a CDDB-DB, AddressBooks, USB-Device-libraries, and of course the Nav-Data with 3d-objects and stuff.

bye
Darky
Appreciate 0
      05-31-2010, 07:37 AM   #9
frayedsheet
Private
Australia
10

 
Drives: 2012 Jeep GC Overland
Join Date: Dec 2009
Location: Sydney, Australia


Posts: 81
iTrader: (0)

Quote:
Originally Posted by Dark-Sider View Post
Hi,



The Harddisk is 80GB, but only 12GB are usable for downloading music. The remaining space is for a CDDB-DB, AddressBooks, USB-Device-libraries, and of course the Nav-Data with 3d-objects and stuff.

bye
Darky
Well id be better off just getting a couple of 4Gb USB sticks which are so cheap.

Basically, it seems in countries other than Germany the professional nav's only advantage is a slightly wider screen and a 3D view angle???
Appreciate 0
      05-31-2010, 03:44 PM   #10
Dark-Sider
X1 driver
Germany
0

 
Drives: X1 1.8d sDrive
Join Date: Mar 2010
Location: Munich, Germany


Posts: 63
iTrader: (0)

Quote:
Originally Posted by frayedsheet View Post
Basically, it seems in countries other than Germany the professional nav's only advantage is a slightly wider screen and a 3D view angle???
You also have DVD-Playback (when not driving). During evaluation I also got my hands on a Business Nav - it felt a little less responding - but not that much that it was a deal-breaker.

The Business-Nav is really sufficient if you just want to go from A to B.

I also can recommend a 250GB 1,8" Harddrive for the USB-Port.

bye
Darky
Appreciate 0
      06-01-2010, 04:11 AM   #11
frayedsheet
Private
Australia
10

 
Drives: 2012 Jeep GC Overland
Join Date: Dec 2009
Location: Sydney, Australia


Posts: 81
iTrader: (0)

Quote:
Originally Posted by Dark-Sider View Post
You also have DVD-Playback (when not driving). During evaluation I also got my hands on a Business Nav - it felt a little less responding - but not that much that it was a deal-breaker.

The Business-Nav is really sufficient if you just want to go from A to B.

I also can recommend a 250GB 1,8" Harddrive for the USB-Port.

bye
Darky
haha... i really cant see myself sitting in the car to watch a whole movie.

So I thought that the USB port didnt accept drives, only flash memory? at least thats what I thought I read.
Appreciate 0
      06-01-2010, 11:43 AM   #12
Dark-Sider
X1 driver
Germany
0

 
Drives: X1 1.8d sDrive
Join Date: Mar 2010
Location: Munich, Germany


Posts: 63
iTrader: (0)

Hi,
Quote:
Originally Posted by frayedsheet View Post
So I thought that the USB port didnt accept drives, only flash memory? at least thats what I thought I read.
BMW warns you about using Hard Disks on the USB-Port. Most 2.5" Disks require a USB-Y-cable connection. USB only specifies 500mA. Those 2.5" disks often need like 750 or 800mA to spin up.

Toshibas 1.8" USB Stor.E disks are rated For 500mA consumption on the USB port and therefore I have no worries connecting the harddrive to the port. The disk just works fine in the car - no fried disk or usb-port yet .

bye
Darky
Appreciate 0
      06-02-2010, 04:31 PM   #13
niknik
Private First Class
Portugal
7

 
Drives: X1 23d
Join Date: Apr 2010
Location: Portugal


Posts: 113
iTrader: (0)

Considering how cheap 16 (and even 32GB) usb sticks are, I feel more confortable not having rotating media bumping around in rough roads.
Appreciate 0
      06-03-2010, 02:21 AM   #14
Frippe
Registered
0

 
Drives: X1
Join Date: Jun 2010
Location: Sweden


Posts: 3
iTrader: (0)

Got my X1 yesterday. Got the iphone snap-in module and it works like a charm, but if I try to connect an iPod Touch to the USB it wont regognize it. It charges but cant access the music on it. Read in the manual that one needs a special cord for it. Any one know any solution on just using a regular iPod USB cable?

Also, when attaching a stick with music, I had trouble accessing the music. Is there any special formatting needed for the stick or some special folder setup on the stick?
Appreciate 0
      06-03-2010, 06:18 AM   #15
Dark-Sider
X1 driver
Germany
0

 
Drives: X1 1.8d sDrive
Join Date: Mar 2010
Location: Munich, Germany


Posts: 63
iTrader: (0)

Hi,

congrats to your new X1!

Quote:
Originally Posted by Frippe View Post
Got my X1 yesterday. Got the iphone snap-in module and it works like a charm, but if I try to connect an iPod Touch to the USB it wont regognize it. It charges but cant access the music on it. Read in the manual that one needs a special cord for it. Any one know any solution on just using a regular iPod USB cable?
You can't use the normal in the X1. You need a special Y-calbe - you can read all about it in this thread: http://e84.xbimmers.com/forums/showthread.php?t=390453


Quote:
Also, when attaching a stick with music, I had trouble accessing the music. Is there any special formatting needed for the stick or some special folder setup on the stick?
Make sure your USB-Stick ist FAT or FAT32 formatted. NTFS, HFS+ or other UNIX filesystems like ext2/3/4 XFS etc. won't work. Are you using a Windows, MacOSX or a LINUX/Unix-based Computer?.

You can create folders on the USB-Stick to structure your music, you can also use .m3u playlists. Just put your mp3, mp4, wma etc. music on the stick and you're done. The failsafe test would be to put a normal, single MP3-File on the stick :-)

bye
Darky
Appreciate 0
      06-03-2010, 07:01 AM   #16
Frippe
Registered
0

 
Drives: X1
Join Date: Jun 2010
Location: Sweden


Posts: 3
iTrader: (0)

Thanks alot for the information.

Guess I am going to BMW to get one of those cable. But my iphone works perfectly in the snap-on holder. See all my music and stuff then.

Got it to work with a stick. Unfortunate, when using MacOS X, OSX has all these hidden files in a folder that you normally dont see when at the computer. But when in the X1 I see them. Will find a solution to get rid of them hopefully.
Appreciate 0
      06-03-2010, 07:24 AM   #17
yohans
Private
2

 
Drives: X1 xDrive20d
Join Date: May 2010
Location: AU


Posts: 60
iTrader: (0)

Quote:
Originally Posted by Dark-Sider View Post
Hi,

congrats to your new X1!


You can't use the normal in the X1. You need a special Y-calbe - you can read all about it in this thread: http://e84.xbimmers.com/forums/showthread.php?t=390453
Well I'm using the standard white Apple iPod cable with an iPod Classic just fine in mine. See my post in the thread Dark-Sider linked above.

I'm confused. Does it work because it's an old iPod (5th Gen) or because of something else.
Appreciate 0
      06-03-2010, 07:52 AM   #18
Dark-Sider
X1 driver
Germany
0

 
Drives: X1 1.8d sDrive
Join Date: Mar 2010
Location: Munich, Germany


Posts: 63
iTrader: (0)

Quote:
Originally Posted by yohans View Post
I'm confused. Does it work because it's an old iPod (5th Gen) or because of something else.
It "works" because your car sees the ipod as a mobile harddisk and accesses the mp3s directly. You don't have playlist-integration etc.

Attach your iPod to your iTunes and select it on the left bar. On the main window in iTunes you should now see in the "summary" tab an options panel. uncheck the "enable disk use" option and your iPod will stop working in your car.

bye
Darky
Appreciate 0
      06-03-2010, 10:13 AM   #19
Frippe
Registered
0

 
Drives: X1
Join Date: Jun 2010
Location: Sweden


Posts: 3
iTrader: (0)

And this is why an iPod Touch wont work as it cant even work in "disk mode"
Appreciate 0
      06-07-2010, 08:47 AM   #20
yohans
Private
2

 
Drives: X1 xDrive20d
Join Date: May 2010
Location: AU


Posts: 60
iTrader: (0)

Quote:
Originally Posted by Dark-Sider View Post
It "works" because your car sees the ipod as a mobile harddisk and accesses the mp3s directly. You don't have playlist-integration etc.

Attach your iPod to your iTunes and select it on the left bar. On the main window in iTunes you should now see in the "summary" tab an options panel. uncheck the "enable disk use" option and your iPod will stop working in your car.

bye
Darky
Ok, what you are saying makes sense. I can't see any playlists only the music through the artist, albums, composer, track options. However, this level of integration for me is pretty good especially as it saves me buying the Y cable

Unfortunately I cannot uncheck the "enable disc use" option to try out your suggestion. It is greyed out in my iTunes.

So I'll happily stay with my white iPod cable until I need to move from the iPod classic. Right now I have no plans to do so.

Thanks for your help.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:35 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST